GPS WEEK ROLLOVER 2019

Eugene Aksyonov

Administrator
5PLS
I just tried twice to do the migration, which I thought I had done months ago...still not successfully though. The software downloads and says it installs then the LS reboots but Linux has not been installed. It apparently creates everything it needs to on the USB stick but the installation apparently never happens. Suggestions?
please, be careful with SD card adapters. some USB flash drives can not be mount on reboot. I do not see any other reasons.
the plan B is to use factory SD and then import data from the usb that you had created while migration before.
Regards,
 

Sean Joyce

Active Member
This is the second time this week-rollover has occurred. GPS week zero started January 6, 1980. The 1024 weeks counter ran out and rolled over on August 21, 1999. The week counter then reset to zero, and it has been recounting ever since. The next time the counter will reach week 1023 and rollover to zero is on April 6, 2019.
And, guess what? That was yesterday.
So, my thoughts are: don't try to "survey through the rollover". Do a firmware upgrade after the rollover, before attempting field work. Pay extra attention to dates, and times.
Expect a little trouble.
Give the mfr's a little room to sort out things. It only happens about once every 19 yrs.
Nate
I started this thread as a heads up on in October 2018, how much time is needed???:confused:
 

Joe Paulin

Active Member
Well, I haven't been on here for a few days, went out yesterday and surveyed. Was puzzled on why I couldn't access my google drive but worked around that issue. This morning I tried to dpos my data but I was getting an error. So I thought I better get on here and see what's going on. I just updated to J-Field 3.0.1.420 and now everything is fine. Google drive is back and dpos worked great.
 

Jim Frame

Active Member
One of the updates turned off upsampling. Turn it on by selecting hardware setup button on the bottom left of the receiver. Click rtk/dgps and set rate to 0.2 seconds and turn upsampling on.
I don't know how it got turned off, but it did. The last time I used it upsampling worked, it was only when I fired it up after the week rollover that it stopped upsampling. That was before I updated to .420.
 

Shawn Billings

Shawn Billings
5PLS
It was part of the update. Two or three updates ago, the setting was changed to 1Hz, Upsampling Off. It's still apparently an issue in the update. It's a pretty simple fix, just not terribly intuitive.
 

Kelly Bellis

ME PLS 2099
5PLS
As I've retired, I had only been sort of paying attention to this thread.

Minutes ago, I received an email notice:
Email notice of roll-over issue.PNG


That was nice to see, and I went ahead and dusted off the LS, turned it on and immediately noticed that the wrong date was being displayed. Note, that I hadn't turned on the LS since October 2018 (still on daylight savings time from last year), nor had any recent updates been applied for quite sometime.

19990825-13.56.19_VKB_Main.png


The status of software versioning before doing anything else:

19990825-13.56.42_VKB_Software_Update.png


With the Ethernet cable plugged into the LS, I went ahead and performed the (3) updates resulting in Jfield v3.0.1.420 , etc.,:

SOFTWARE-UPDATE_20190410-14.43.17.png



Afterwards, the Home screen showed the correct time, but I noticed that there was an oddity showing up for the Files icon:

Files icon looking flukey.PNG


Pressing and hold down on the icon subsequently brought up a confusing notice regarding Eject Dongle, though no such dongle is present.

HOME-1_20190410-14.47.57.png


The first time I tapped on broad button labeled SD Card and went to browse the files, the SD Card was absent. Then I performed a full power cycle of the LS and waited several seconds before powering it back on. Once booted, the odd looking Files icon still appeared, and pressing and holding it brought up the Eject Dongle notice again. Tapping on the broad button labeled SD Card appeared to do nothing, and the odd Files icon remained unchanged on the Home screen.

Tapping on the Files icon brought up the familiar option to Browse Files, which I did wherein it appeared thus:

BROWSE-FILES_20190410-14.51.50.png


After browsing the SD card, everything seems in order with nothing looking alarming; however, it remains unclear to me why the odd Files icon lingers:

20190410-15.12.18_VKB_Main.png


I've been holding off on doing some pro bono work for NGS while it seems there's no end to this winter, but am hoping to get this business ironed out before the ground clears of snow.

Kind regards,

Kelly

PS. A belated Happy Nowruz to all of my Persian friends!
 

Kelly Bellis

ME PLS 2099
5PLS
@ Matt J
That thread seems related to USB. I rarely have a USB device plugged into the LS; however, I've always had the SD card in use, the same SD card that Michael Glutting provided particularly for the LS... not that should mean anything, it's just that it has never proven to have any issues. Are you saying that this issue hasn't been fixed?

Why should the SD card be ejected in the first place?
 

Matt Johnson

Well-Known Member
5PLS
Most users are not going to be regularly ejecting the SD card but that option is there in case someone wants to.
 

Kelly Bellis

ME PLS 2099
5PLS
Hi Eugene,

My consternation over the use of the word 'dongle' aside, it's the need to call such attention to 'eject' an SD card that's got me flummoxed. There's thousands of devices all quietly being serviced by these tiny marvels, none of which have new icons popping up suggesting that there is something to be alarmed about and that I need to be concerned with its immediate extraction. The mere fact that such an operation to remove the LS's micro-SD card requires surgical tweezers is reason enough to presume that it won't be yanked in and out like a USB flash drive.

I get that there's reasons to unmount the SD properly, but maybe there's a better way it could be presented - that's all I'm trying to say.
 

Steve Douty

Active Member
I am not cleaqr on what I should do. Can/should I ignore the "Eject" notice or not. Please provide clear step by step instructions for those of us who don't want to expermint.
 

Eugene Aksyonov

Administrator
5PLS
ok. I see. You consider this icon as an alert that forces you do something. This is not the case, really. Maybe it is wrong place to put such status of mounted media?
Should we move it into "Browse Files" screen options instead? But then you will not see status easily. And as a result - not unmounting media properly. Change the Icon to different color? show two different icons for SD and USB stick?
 

Kelly Bellis

ME PLS 2099
5PLS
ok. I see. You consider this icon as an alert that forces you do something. This is not the case, really. Maybe it is wrong place to put such status of mounted media?
Should we move it into "Browse Files" screen options instead? But then you will not see status easily. And as a result - not unmounting media properly. Change the Icon to different color? show two different icons for SD and USB stick?
Consider leaving the Home screen 'Files' icon unaltered and in the screen linked from it work in something obvious like the following:
TRIUMPH-LS_Mount_icons.png

The zipped up .ai attached is for Alexandra or Kseniya if desired.
 

Attachments

Top