LS and trajectory...

John Thompson

Active Member
Mikhail,
Here is my trajectory, my export setup, and the export preview. I want the point names to be the trajectory name concatenated with sequence number, but it names them ShapeTag-sequence number. What am I doing wrong here?

00229_Trajectory_Info_20160909-07.25.03.png 00229_Export_File_Format_20160909-07.25.36.png 00229_Export_File_Preview_20160909-07.25.41.png
 

John Thompson

Active Member
I did a bunch of topo with the LS on my ATV using trajectories the other day. There are a couple trajectories from which I can't export the points. I've tried both csv and dwg export formats. The points appear on the map on the LS, but if I check Line Name under View Attributes, they don't appear to have line names. If I'm not mistaken, both of the problem trajectories were the first trajectories collected on each day.

I sent the project to support. Phillips County Fairgrounds. Problem trajectories are on Page 2018-06-12. Examples of unexported points are near (3579939, 7152257) and (3579089,7151539). There are also trajectories in that project that were collected last year sometime on earlier pages. No problems with them.
 

Mikhail Drakin

Developer
5PLS
I've reproduced the problem with the project and will investigate it. Did you notice something unusual while you were collecting that trajectories?
 

John Thompson

Active Member
I collected more trajectories with that same project yesterday. Again, the first trajectory collected has no name and did not export. This time, though, the first trajectory was junk shots, so I can export the points I needed.
 

Darren Clemons

Well-Known Member
I just don't do these often enough to remember "did I have to do this last time?", but surely I'm missing something. Of course, it is 6:10 am where I am, so maybe it's I'm not awake yet. :confused:

I just exported all my trajectories from a job yesterday and I can't for the life of me figure out how to export them all at once instead of having to select one trajectory at a time.

I checked the additional actions and it does give me a multi select actions where I can select them all, but that seems to only let me delete them all at once from the LS - not export them all at once.

Maybe I've had to do this every time, but surely there's a way to do them all at once in one text file. Doing the same entire export process 5, 8, 12 times, etc. and then having to import all of them separately into Cad is not very smooth.
 

Darren Clemons

Well-Known Member
"What to Export" -> "All Page Trakectories as Points" option? Of course it puts them in one file, but inside the file they differ by name and thus can be sorted out after export.
Yep. That did it! I may have found this last time but couldn't this time. Not concerned about the numbering or sorting as after Shawn's suggestion I now just make a seperate Cad file and .crd file called "trajectories" - draw them all with nodes and elevations - then copy and paste to original coordinates in my main Cad drawing of the project. These never get associated with my main crd file, therefore do not jumble it up with thousands of points.

Thanks Mikhail!
 

John Thompson

Active Member
I sent another project to support. Rayl SN229. Looks like another trajectory that won't export. I set up my base across town from the project site at a point I've used for a base many times before. I collected a trajectory covering about the north third of this lot, then had some trouble getting a fixed solution. My first thought was that the Jetpack had overheated and shut off, so I went back to the base and it was still running. I tried rebooting LS, T2, and Jetpack, restarting the base, etc. I fought with it for a couple hours trying to get a fix that would stay until I got back to the site. I think the Jetpack may have had insufficient Verizon signal, though it's never been a problem before. I eventually moved my base to the project site, started the base autonomously, then shifted. I continued observing trajectory over the rest of the lot and I had no further problems until I tried to export the trajectory. The trajectory marks appear on the map but not in the list. Can you work some magic and recover these points or will I need to collect them again? Thanks.
 

John Thompson

Active Member
I sure did! Now THAT'S customer service and support! I sent that project to support after 3:00 p.m. and got ready to go re-collect the points I needed first thing in the morning. I woke up at 5:00 this morning and in my email inbox was the zip file of the project with the trajectory recovered. It had been there over 2 hours. Well done, Attaboy, and Kudos to Michael! The Javad Team is second to none! O that all my troubles could be fixed while I sleep. :)
 

Nate The Surveyor

Well-Known Member
I've lost several trajectories. They are not showing up graphicly in the LS, and are not exporting.
I'm guessing I fat fingered it, but if there were a chance for recovery, it'd save me a day of work.
Thanks.
Nate
 

Michael Stazhkov

Developer
Staff member
5PLS
I've lost several trajectories. They are not showing up graphicly in the LS, and are not exporting.
I'm guessing I fat fingered it, but if there were a chance for recovery, it'd save me a day of work.
Thanks.
Nate
If trajectory is not showed on the map - it is bad sign. But did you check on "Trajectory Marks" in the map "View Attributes"? Any way just send the project to support I will look.
 
Top