Background Maps

Michael Stazhkov

Developer
Staff member
5PLS
I use NCONEMAP. Download the parcel data by county as a shapefile. I import the shapefile into my office software and then save it as a dwg. For each project I open up the county drawing and copy the lines in the area I will be working and export those a dwg for the LS. It works great but it is a lot of steps to get it in there.
Adam, J-Field supports shapefile import. Is the file too large for J-Field map? Will it help if we import the shapefile as an additional background layer for the project?
 

Adam

Well-Known Member
5PLS
The files are by county so yes, they are huge. Importing the shapefile as a background layer would be good, I think. I don't ever actually stake to these lines. They are just a visual to get close.
 
I would like to believe that all the parcel data is free because of the Freedom of Information Act. Getting the data from all those sources and making it work on a map is the trick that these software providers charge for.
 

nusouthsc

Member
I personally prefer importing shape files myself. We use a free GIS software called QGIS and pay a few hundred dollars to buy all our county shape files. I like having the control of what's in the LS map and the ability to manipulate it also. The last thing I would want is lines in the wrong location cluttering the map that can't be turned off. That would be a nice feature but in reality a phone works just fine also. The app Huntstand for your phone is free and has parcel data. Just my $0.02.
 

Phillip Lancaster

Active Member
Nate. All that data that you're talking about is in Arkansas and can be downloaded for free. I normally download the entire county as one file and just write block the area I need. I import the data in .dwg
 

APADDEN07

Member
Trying to change my background map for a job in the wilderness this week. The LS+ completely freezes up and I have to turn it off and restart. The 'reading background maps' message comes up and then eventually the screen times out and nothing will bring it back up. Anyone else having a similar issue?

LS+ running 3.0.10.414
I now get this error when entering the background maps screen (see below). From the home screen, I do the following Action > Project > Edit Current Project > Background Map > Then I get a message box that pops up and says "reading background maps" > then I get the screen below.

LS+ #00998, NOW running 3.0.11.788

Currently connected to RAMS




r4B5LD95PszAxnyehEbhDaInIR-UpsI7Sq4EmPQUNNwPWu3bNZ-T3Gu3Yfi1JKg5Csn7PoMsAFca6hjY2cbob-eW9Tn7QbWaGsSttRkWpwcPLu_OKQhH3HprCOxjwqBtgy56AW3a25b2MlXY2JOeB1TPczvwWbK5YVNbZ1JRMh7dCsOeavdD_CbpIZ1BPHSV2nNSPIVCVprxhdnFEoRMNlmh9Or2nM922DL1mfyLWAvpulNejN6xWl0XB8u1btQu4uYWqlIHOyxj5bdlJrio0nkHEYUlwXdsiQiLIwvemTUVgME8ylph5TL7JBjrCLP66FcPmzOlXK11-KG6nr_CD_0C8t_yEKWO6cmWn_qZsffTl1luaLH_UY8BAE6rlhwZeXftqIDneALmm6HX22PhLAVlgkpZlFx_ZeeQeIn5oFxKxPnrsUrCKzw0tZj-MTh6YmUZnfwG2RzaUA7mw5-l-QLHkkKPc9vbtq3dcS4a_F18MWowPWhAr_Ujq0DIc12221qBLzYfNKs7m6JiMO4Sc_4EnbuNefSU_aNAFI216OA7kgmAgvA_QzrXzLKv8qf5Spm1wl-o0_USSJQmdDDpQRWipLAT9ahs08ZTvoP1sBFrBCbZt4bpEbpUOFG1_n5aKt0CVxMutdHbcbf9vSAXaxPWJb6OoyfI8qzQXV76BmzX-jwHiSJxYjI43FDUwWDTddNGysL5r19qP_TQLrPqyRp-pg=w838-h628-no
 

Matt Johnson

Well-Known Member
5PLS
I now get this error when entering the background maps screen (see below). From the home screen, I do the following Action > Project > Edit Current Project > Background Map > Then I get a message box that pops up and says "reading background maps" > then I get the screen below.

LS+ #00998, NOW running 3.0.11.788

Currently connected to RAMS




r4B5LD95PszAxnyehEbhDaInIR-UpsI7Sq4EmPQUNNwPWu3bNZ-T3Gu3Yfi1JKg5Csn7PoMsAFca6hjY2cbob-eW9Tn7QbWaGsSttRkWpwcPLu_OKQhH3HprCOxjwqBtgy56AW3a25b2MlXY2JOeB1TPczvwWbK5YVNbZ1JRMh7dCsOeavdD_CbpIZ1BPHSV2nNSPIVCVprxhdnFEoRMNlmh9Or2nM922DL1mfyLWAvpulNejN6xWl0XB8u1btQu4uYWqlIHOyxj5bdlJrio0nkHEYUlwXdsiQiLIwvemTUVgME8ylph5TL7JBjrCLP66FcPmzOlXK11-KG6nr_CD_0C8t_yEKWO6cmWn_qZsffTl1luaLH_UY8BAE6rlhwZeXftqIDneALmm6HX22PhLAVlgkpZlFx_ZeeQeIn5oFxKxPnrsUrCKzw0tZj-MTh6YmUZnfwG2RzaUA7mw5-l-QLHkkKPc9vbtq3dcS4a_F18MWowPWhAr_Ujq0DIc12221qBLzYfNKs7m6JiMO4Sc_4EnbuNefSU_aNAFI216OA7kgmAgvA_QzrXzLKv8qf5Spm1wl-o0_USSJQmdDDpQRWipLAT9ahs08ZTvoP1sBFrBCbZt4bpEbpUOFG1_n5aKt0CVxMutdHbcbf9vSAXaxPWJb6OoyfI8qzQXV76BmzX-jwHiSJxYjI43FDUwWDTddNGysL5r19qP_TQLrPqyRp-pg=w838-h628-no

Did you try clearing the tiles like I suggested? It seems this is probably not possible now to get to that option.
 

Michael Stazhkov

Developer
Staff member
5PLS
I now get this error when entering the background maps screen (see below). From the home screen, I do the following Action > Project > Edit Current Project > Background Map > Then I get a message box that pops up and says "reading background maps" > then I get the screen below.

LS+ #00998, NOW running 3.0.11.788
Could you tell the password.
 

Michael Stazhkov

Developer
Staff member
5PLS
I now get this error when entering the background maps screen (see below). From the home screen, I do the following Action > Project > Edit Current Project > Background Map > Then I get a message box that pops up and says "reading background maps" > then I get the screen below.

LS+ #00998, NOW running 3.0.11.788

Currently connected to RAMS




r4B5LD95PszAxnyehEbhDaInIR-UpsI7Sq4EmPQUNNwPWu3bNZ-T3Gu3Yfi1JKg5Csn7PoMsAFca6hjY2cbob-eW9Tn7QbWaGsSttRkWpwcPLu_OKQhH3HprCOxjwqBtgy56AW3a25b2MlXY2JOeB1TPczvwWbK5YVNbZ1JRMh7dCsOeavdD_CbpIZ1BPHSV2nNSPIVCVprxhdnFEoRMNlmh9Or2nM922DL1mfyLWAvpulNejN6xWl0XB8u1btQu4uYWqlIHOyxj5bdlJrio0nkHEYUlwXdsiQiLIwvemTUVgME8ylph5TL7JBjrCLP66FcPmzOlXK11-KG6nr_CD_0C8t_yEKWO6cmWn_qZsffTl1luaLH_UY8BAE6rlhwZeXftqIDneALmm6HX22PhLAVlgkpZlFx_ZeeQeIn5oFxKxPnrsUrCKzw0tZj-MTh6YmUZnfwG2RzaUA7mw5-l-QLHkkKPc9vbtq3dcS4a_F18MWowPWhAr_Ujq0DIc12221qBLzYfNKs7m6JiMO4Sc_4EnbuNefSU_aNAFI216OA7kgmAgvA_QzrXzLKv8qf5Spm1wl-o0_USSJQmdDDpQRWipLAT9ahs08ZTvoP1sBFrBCbZt4bpEbpUOFG1_n5aKt0CVxMutdHbcbf9vSAXaxPWJb6OoyfI8qzQXV76BmzX-jwHiSJxYjI43FDUwWDTddNGysL5r19qP_TQLrPqyRp-pg=w838-h628-no
Something wrong with your SD card. Files -> Full backup and restore screen also cause the exception. I have unmount SD card and the exception disappears.
Please check SD card on your computer. And if you will find something wrong with it please tell what.
Of cause it is no good that jfield produce exception. We will analyze the place where it happens.
 

APADDEN07

Member
Ran the standard utility that comes up on windows 10, said the sd card had errors. Ran the check/repair function and everything looks fine. Can't seem to find the event in the event viewer though. The closest thing to the right time is this, but I don't think that's the one. If there's somewhere else I should look let me know. Putting it back on RAMS. for a little while. I need it this afternoon though.

Log Name: System
Source: Microsoft-Windows-DistributedCOM
Date: 5/12/2021 11:30:48 AM
Event ID: 10016
Task Category: None
Level: Warning
Keywords: Classic
User: DESKTOP-LF03DFT\Bill 2018
Computer: DESKTOP-LF03DFT
Description:
The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
{C2F03A33-21F5-47FA-B4BB-156362A2F239}
and APPID
{316CDED5-E4AE-4B15-9113-7055D84DCC97}
to the user DESKTOP-LF03DFT\Bill 2018 SID (S-1-5-21-3451059576-3071406178-1815477765-1002) from address LocalHost (Using LRPC) running in the application container Microsoft.Windows.ShellExperienceHost_10.0.19041.964_neutral_neutral_cw5n1h2txyewy SID (S-1-15-2-155514346-2573954481-755741238-1654018636-1233331829-3075935687-2861478708). This security permission can be modified using the Component Services administrative tool.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
<EventID Qualifiers="0">10016</EventID>
<Version>0</Version>
<Level>3</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8080000000000000</Keywords>
<TimeCreated SystemTime="2021-05-12T15:30:48.8129682Z" />
<EventRecordID>8021</EventRecordID>
<Correlation ActivityID="{c5448f63-9e47-4562-90cc-ef8cb15a35d0}" />
<Execution ProcessID="1188" ThreadID="14672" />
<Channel>System</Channel>
<Computer>DESKTOP-LF03DFT</Computer>
<Security UserID="S-1-5-21-3451059576-3071406178-1815477765-1002" />
</System>
<EventData>
<Data Name="param1">machine-default</Data>
<Data Name="param2">Local</Data>
<Data Name="param3">Activation</Data>
<Data Name="param4">{C2F03A33-21F5-47FA-B4BB-156362A2F239}</Data>
<Data Name="param5">{316CDED5-E4AE-4B15-9113-7055D84DCC97}</Data>
<Data Name="param6">DESKTOP-LF03DFT</Data>
<Data Name="param7">Bill 2018</Data>
<Data Name="param8">S-1-5-21-3451059576-3071406178-1815477765-1002</Data>
<Data Name="param9">LocalHost (Using LRPC)</Data>
<Data Name="param10">Microsoft.Windows.ShellExperienceHost_10.0.19041.964_neutral_neutral_cw5n1h2txyewy</Data>
<Data Name="param11">S-1-15-2-155514346-2573954481-755741238-1654018636-1233331829-3075935687-2861478708</Data>
</EventData>
</Event>
 
Top