Dissapointed in Javad Legacy Software!

I have spent more that 12 hours just trying to get my computer to communicate with JAVAD's 404BT Radio.
I have followed all instructions, but, the ModemVU will not connect with the 404BT. I have check the port's information, but all I get is a denial (start with administrator rights). Once I did connect but the update failed. WTF! There has to be a better way!
 

Nate The Surveyor

Well-Known Member
I tried several times, found that my computer actually could recognize it, as a SERIAL port number... (I think it was number 5!) AFTER recognizing it, I tried to update the radio. It went about 1/2 way, and crashed my computer. My computer is an older one, with MS XP in it. I like XP. I did this 4x. I think if mine had more ram. (I think it has 3 megs of ram) then it would go. I wound up at another surveyors office, and he has a better computer. It would NOT function with a USB port. But, once again, did ok with a Serial port, through a USB port. And, it took some 20 mins to get the update. His is MS windows 7.
So.... I also will like the radio updates through the LS.... How is that coming?

Thanks!

N
 
Any word on radio update through LS? Cannot seem to communicate in Modem VU with Triumph IM radios through USB serial ports. Tried two computers tonight will try some more tomorrow.
 

Matt Johnson

Well-Known Member
5PLS
Any word on radio update through LS? Cannot seem to communicate in Modem VU with Triumph IM radios through USB serial ports. Tried two computers tonight will try some more tomorrow.
This has been finished and will be available in the next release. Are you running ModemVU as an administrator? For Windows 7 and greater it must be started as an administrator by right clicking on its shortcut and choosing "Run as administrator".
 
Matt
Thanks for reminding me about the "Run as administrator". I have that written down somewhere but it's been a few months since I changed the radio firmware in my Triumph 1M's. Still not having much luck. Get message "The internal radio is not detected". Happens on both units. The radios are working. Running Modem VU 2.1.54 build April 14,2015. Using serial cable through port a on Triumph.
 

Matt Johnson

Well-Known Member
5PLS
Jim I asked the firmware team about this and they have some questions:

1. What program generates this error message?

2. What versions of GNSS firmware and Modem firmware installed into Triumph-1M?

3. What serial number this Triumph-1M?​
 
1. What program generates this error message? ModemVu

2. What versions of GNSS firmware and Modem firmware installed into Triumph-1M?
Tried this again this morning

Didn't work configuration
Triumph 1M S/N 25087 LMR400 ID 74 S/N 000004052967
GNSS Firmware 3.6.3
Radio Firmware 3.2 Rev 04 B18
Modem Vu version Modem VU 2.1.54 build April 14,2015 - Windows 10 Pro

Did work configuration
Triumph 1M S/N 25088 LMR400 ID 74 S/N 000004052945
GNSS Firmware 3.6.3
Radio Firmware 3.2 Rev 04 B18
Modem Vu version Modem VU 2.1.54 build April 14,2015 - Windows 10 Pro

3. What serial number this Triumph-1M?
Triumph 1M S/N 25087 LMR400 ID 74 S/N 000004052967 - does not work with ModemVu
Triumph 1M S/N 25088 LMR400 ID 74 S/N 000004052945 - works with ModemVu

Okay pretty sure this is an issue with the radio in 25087. I am able to connect to 25088 through ModemVu but have failed on several attempts with 25087. I was able to install Radio Firmware 3.2 Rev 04 B30 in 25088. I have some anecdotal evidence that the radio in 25087 is suspect. When I try to use it as a base it does not always work. I have blamed that on operator error as I am not that proficient with these receivers - getting there fast. The receiver is working fine as a rover but I am only 75 feet from the base.

Its funny when I got the receivers last September I designated 25087 as the base - got things to work but it was only intermittent and seemed to have a range problem. Pretty much gave up on them and went back to my Topcon GR3. After trying again last week I decided to switch the roles of 25087 and 25088. Still haven't taken the new configuration to the field but not working for an unknown reason has gone away.
 

Vladimir Zhukov

Well-Known Member
Staff member
5PLS
Hi Jim, We will provide advanced replacement for the both units. Does it sounds to be acceptable for you?
Anyway the most of you expain sounds very strange and unusual.

What is your workflow with TRIUMPH-1M? Is any another third party field software involved in configuring of TRIUMPH-1M?
 
Last edited:
No third party software. Mostly configure units through Netview. Mostly doing testing with Triumphs. Have external antennas and event markers on both units. Learning how to program Victor LS to mimic setup of Netview when it connects.
Is there an issue with 1M radio that has shown up before? External antenna and event marker are not common features. Any replacements would have to have that capability.
 

Nate The Surveyor

Well-Known Member
Maybe it's just too cold! (Alaska)

Seriously, Javad is serious about making things work.

They sent me a new radio, when mine was just a few weeks old. It was overheating, and shutting off.

I don't know if they ever found out why.

I have a laptop, with 4 USB. ports. The 2 on the right won't work. It refuses to communicate with the t2. (NetView)

My other computer does fine.

There are drivers that run these communication ports. After I get my laptop back from the shop, we will see If it works. At this point, I'm blaming the laptop....

Nate
 
Vladimir
Just to be sure tried ModemVu with 1M S/N 087 again this morning. Did not work see attached jpg.
Disconnected and checked status of radio and it is on and working as an rtk rover.

will the this netview screen capture address the UHF settings. The 087 radio works the problem is that ModemVu will not recognize it. I use /dev/ser/d for the modems. I don't think that is a problem as ModemVu works with 088.
netviewscreen.jpg

Jim
 

Attachments

Vladimir Zhukov

Well-Known Member
Staff member
5PLS
Hi Jim, thank you

Settings are not correct.

The modem D mode shall be OFF in TRIUMPH-1M if internal radio is being used.

First please clear NVRAM to start from the beginning.

1. Configure modem C without touching field Receiver port. Only frequency, modulation, Channel banwidth, outpur power.
As said do not touch Receiver port... field.

2. Enable mode AUTO of modem C
Wait for status Ready

3. Then go to another window Ports-> Serial and configure output mode of serial port D if this is the base and input mode if this is rover.

This is specific of manual progarming, which is not visible if J_FIELD or other is being used.

Actually you can use JMT for more automated programming of base/rover configuration for TRIUMPH-1M.
 
at 7:01 I wrote Thank you. I am now able to upgrade radio firmware on 087.
at 7:14 i wrote
If JMT is Javad Mobile Tools for Android I do use that and I like it so much I tried to send back my Victor LS as a trade in for the SigmaD I am getting but alas no takers.

Thanks again for walking me through this. I figured I was doing something wrong.

These messages did not show up in the thread.
 
What I learned -
First if your up in the middle of the night the guys in Moscow are right on top of things.
Second if you can't connect with ModemVu
Remember to open ModemVU as administrator
If you still can't get on - reset the NVRAM - you probably made a bad assumption about how the receivers work.
If you still can't connect then you have a real issue

Sorry I hijacked a thread with such a poor title was just looking for a method to update the firmware in my radios.
 

Vladimir Zhukov

Well-Known Member
Staff member
5PLS
Hi Jim, thank you for positive feedback.

Please confirm if system is working for you now and advanced replacement is not nessary

Yes, JMT is Javad Mobile Tools.
 
Top